PHP: Hypertext Preprocessor, popularly called PHP, is a popular general-purpose web programming language, which is used to build dynamic websites with interactive features like discussion forums, online teaching websites or social networking websites. In contrast with static HTML-based sites, a PHP website can serve different content to each visitor under the same exact page URL. As PHP-based Internet applications can be managed via a Control Panel, which you can log on to using any web browser, you will not need any coding expertise or practical experience whatsoever in order to run a PHP website. The fact that 100s of millions of websites all over the world are built with PHP is indicative of the popularity and the simplicity of use of the language. You should only check if the web server where you host your website supports the same exact PHP version as the one that you used whilst building the website.

PHP 4 and PHP 5 Support in Cloud Hosting

With our Linux cloud hosting, you’ll be able to pick the PHP version that will be enabled for your shared web hosting account, as different versions are available on our servers. With just one click, you will be able to switch between PHP 5.5, 5.4, 5.3, 5.2 and 4 and each time a new version is published in the future, we will add it to the Hepsia hosting Control Panel without removing the previous ones. In this way, you’ll be able to host all the websites that you have developed throughout the years. In stark contrast to lots of other web hosts, we won’t compel you to update such sites, as a script may be out of date, but this doesn’t mean that it’s vulnerable as you may have implemented modifications to its source code to fill security holes. For the sake of your convenience, you will even be able to specify a different PHP version for each individual website hosted in your shared web hosting account.

PHP 4 and PHP 5 Support in Semi-dedicated Hosting

Even if your websites were built with an older PHP version, you’ll be able to host them in a semi-dedicated server account from us, as we support multiple versions running at the same time on our servers and each one of them can be activated for your account with no more than a click of the mouse from our custom-developed Hepsia hosting Control Panel. Other than the newest PHP 5.5 and PHP 5.4, we also offer support for 5.2, 5.3 and the older PHP 4, which has already been dropped by most hosting suppliers, but we reckon that you shouldn’t be compelled to modify a website that took several years to set up, since older scripting language syntax doesn’t necessarily equal security breaches. On the contrary, a properly maintained site using PHP 4 can be more reliable than an incompetently maintained one using PHP 5. For your convenience’s sake, we’ll also give you the opportunity to set a different PHP version for each individual site within the account.